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What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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Getting Started with PIC32
DOCUMENT LAYOUT 
This document is divided into 6 sections. Sections 1 through 4 provide an overview of 
PIC32 products. Section 5 provides an overview of PIC32 development tools. Section 
6 describes the procedure to setup a development environment and debug a sample 
application. The manual layout is as follows:
• Chapter 1. PIC32 Features
• Chapter 2. PIC32 Product Family
• Chapter 3. PIC32 Architecture
• Chapter 4. PIC32 Tools
• Chapter 5. Step-by-Step Procedures to Setup, Build, and Run a Demo 

Project 
• Chapter 6. Technical Support Resources
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Preface
CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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GETTING STARTED WITH PIC32

Chapter 1.  PIC32 Features
1.1 INTRODUCTION
The PIC32 is a 32-bit family of general purpose microcontrollers from Microchip 
Technology. It offers 80+ DMIPS performance with a wide variety of on-chip periph-
erals. It employs industry leading M4K MIPS32 core from MIPS Technologies, Inc. 
All members in the PIC32 family use programming interface similar to other Micro-
chip PIC® microcontrollers. In addition, PIC32 microcontrollers are pin-to-pin com-
patible with the PIC24FJ128GA family of 16-bit microcontrollers.

1.2 HIGHLIGHTS
The PIC32 family offers a number of features to enable a wide variety of applications. 
The following subsections list all the key features grouped in major categories.

Performance:
• Up to 80 MHz, MIPS M4K 32-bit core with 5 stage pipeline
• High-performance hardware multiply/divide unit – 1 multiply per clock
• Programmable user and kernel memory partition for enhanced application stability
• Multiple register sets for reduced interrupt latency
• Hardware assisted single-cycle register bits manipulations
• 128-bit wide Flash memory to shorten individual instruction fetch time
• 256 bytes of high-speed cache memory with instruction and ROM data prefetch 

buffer
• Available DMA controller with integrated CRC calculation and pattern-based 

transfer termination
• Includes USB On-The-Go controller for USB device, host, or dual-role 

applications
• USB controller has own dedicated DMA interface

Power Management:
• 2.3 to 3.6V operation
• Full-speed operation over entire voltage range
• Various low-power modes including RUN, IDLE and SLEEP
• I/O transfers via DMA in IDLE mode
• Programmable peripheral clock
• Individual peripheral ON/OFF control and operation during IDLE mode
• Multiple clock sources

Scalability:
• Industry known MIPS32-compatible M4K CPU core with 5 stage pipeline
• Large family of devices with Flash memory options from 32 KB to 512 KB
• Pin compatible with 64/100 pin PIC24FJXXXGA family of 16-bit microcontrollers 
© 2008 Microchip Technology Inc. DS61146B-page 7



Getting Started with PIC32
Ease of Use:
• PIC® microcontroller “look and feel” peripherals
• Standard MPLAB® tool-suite – MPLAB IDE, MPLAB C32 C Compiler, MPLAB 

REAL ICE™, and MPLAB ICD 2.
• Software Peripheral Libraries compatible with those for Microchip 16-bit 

microcontrollers
• Microchip developed middleware modules such as TCP/IP and 16-bit file system
DS61146B-page 8 © 2008 Microchip Technology Inc.



GETTING STARTED WITH PIC32

Chapter 2.  PIC32 Product Family
2.1 INTRODUCTION
The PIC32 family includes scalable devices ranging from 32KB to 512KB of Flash 
memory. Also a rich set of peripherals – Five timers, 16 channels of 10-bit A/D 
Converters and communication interfaces: SPI, I2C™ and UART.
Please consult the “PIC32MX Family Data Sheet” (DS61143) for a complete list of 
family variants, core and peripheral characteristics.

FIGURE 2-1: PIC32 MCU MODULES
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Getting Started with PIC32
Processor core:
• MIPS M4K with 5-stage pipeline
• MIPS32-compatible Release 2 Instruction Set
• MIPS16e™ Code Compression to improve code density by up to 40%
• GPR shadow registers to minimize latency for interrupt handlers
• Bit field manipulation instructions
• High-performance Multiply/Divide Unit:

- Maximum issue rate of one 32x16 multiply per clock
- Maximum issue rate of one 32x32 multiply every other clock

• Static implementation: minimum operating frequency 0 MHz
• 2.3 to 3.6V operation with full speed over entire range
• Low-power modes including RUN, IDLE, and SLEEP

Memory:
• Unified 4GB virtual memory space
• Fixed Memory Mapping Translation (FMT) mechanism
• Flexible partitioning into kernel and user accessible memory segments for 

increased application stability

Pre Fetch Cache:
• 16 lines, each 128-bit wide, instruction Prefetch buffer
• Ability to load and lock lines – useful to create SW breakpoints in Flash and 

minimize interrupt latency

Interrupt Controller:
• Fully programmable interrupt controller with Single or Multi vector mode, support-

ing up to 95 IRQs.
• Multiple priorities and subpriorities for each vector
• Highest priority interrupt has dedicated register set for reduced interrupt latency

DMA Controller:
• Up to 4 independent channels
• Memory-to-Memory, Memory-to-Peripheral, and Peripheral-to-Memory transfers
• Programmable trigger from any IRQ
• Chainable channels, stop on match detection, Auto-Enable mode
• Data transfers can occur while the core is in IDLE mode
• Integrated programmable CRC engine: calculates on the fly while the data is 

transferred.

Enhanced Parallel Master Port:
• 8- and 16-bit data interface
• Up to 16-bit address lines, expandable using GPIO lines
• 2 Chip Select lines
DS61146B-page 12 © 2008 Microchip Technology Inc.



PIC32 Architecture
Communication channels:
• USB 2.0 compliant (FS. 12 Mbps), OTG, Host and Device-only capable
• 2 enhanced UART channels with hardware IrDA®

• 2 Master/Slave/Frame mode SPI channels
• 2 Master/Slave I2C channels, 10/7 bits mode addressing, broadcast capable

Analog-to-Digital Converters:
• Up to 16 Channels, each 10-bit resolution ADCs
• Up to 500+ kilo-samples per second (ksps) conversion speed
• Software selectable Internal or External voltage reference
• Automatic Channel Scan mode
• Selectable conversion trigger source
• 16 word conversion result buffer
• Selectable Buffer Fill modes
• Eight result alignment options 
• Operation during CPU Sleep mode

Timers:
• 5 16-bit timer/counter with the ability to form up to (2) 32-bit timer/counters
• Software-selectable internal or external clock source
• Asynchronous timer/counter with built-in oscillator
• Programmable interrupt generation and priority
• Gated external pulse counter
• Software-selectable prescalers.
• Operational during CPU Sleep mode

Core Timer:
• 32 bit timer in CPU for implementing a timer interrupt function.

RTCC (Real-Time Clock and Calendar):
• Time with hours, minutes and seconds
• Calendar with weekday, date, month and year
• Leap year detection
• Highly configurable alarm
• Calibration of up to 260 ppm of crystal error

Debug and Programming:
• 6 instructions and 2 data breakpoints
• 2 complex breakpoint logic blocks with qualified/primed breakpoint triggers, Pass 

counters, and stopwatch timers.
• 4-wire EJTAG and 2-wire Microchip interface
• 2-wire Microchip Interface:

- 6 real-time read/write capture logic blocks
- Read/write access to all data RAM and SFRs without stopping CPU

• Instruction Trace Port:
- 5-Wire, nonintrusive trace port
- Triggered by complex breakpoint logic block
© 2008 Microchip Technology Inc. DS61146B-page 13



PIC32 Tools
4.6 SOFTWARE SOLUTIONS
At the time of writing this document, Microchip had not released any drivers. Microchip 
does intend to develop drivers for key communication peripherals. 

4.6.1 Middleware
The following list provides the Microchip middleware components available at the time 
of writing this document:
• 16-bit  file system on SD Memory to support Microsoft MS-DOS file system.
• Two types of TCP/IP stack – 1) Microchip legacy TCP/IP Stack – fully compatible 

with Microchip 8- and 16-bit Stack, 2) Microchip BSD TCP/IP Stack – A Berkeley 
socket API stack with many advanced features.

• TCP/IP middleware: 
- FTP server to allow the application running on the target PIC32 machine to be 

a File Transfer Protocol server.
- SNMP Agent to monitor PIC32 products using SNMP protocol.
- Web server to accept HTTP requests from Web browsers clients.

• USB middleware:
- USB Embedded Host Stack (HID and Mass Storage)
- USB Device Stack (HID, Mass Storage and CDC class)

4.6.2 3rd Party Tools
Check the PIC32 home page (www.microchip.com/PIC32) to learn about the list of 
companies with support for PIC32.
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Getting Started with PIC32
5.3.3 Running MPLAB IDE
To start MPLAB IDE, double click on the icon installed on the desktop after installation 
or select Start>Programs>Microchip>MPLAB IDE vx.xx>MPLAB IDE. A screen will 
display the MPLAB IDE logo followed by the MPLAB IDE desktop.

FIGURE 5-1: MPLAB IDE START SCREEN

5.4 STEP-BY-STEP GUIDE OVERVIEW
To create code that is executable by the PIC32 MCU, source files need to be part of a 
project. The code can then be built into executable code using selected language tools 
(assemblers, compilers, linkers, etc.). In MPLAB IDE, the project manager controls this 
process and will guide us through most of these steps.
All projects will have these basic steps:

- Select Device
The capabilities of MPLAB IDE vary according to which device is selected. Device 
selection should be completed before starting a project.

- Create Project
MPLAB IDE Project Wizard will be used to create a project.

- Select Language Tools
In the Project Wizard the language tools will be selected. For this tutorial, the PIC32 
tools will be used. For other projects, either other Microchip or third party tools might 
be selected.

- Add Files in Project
We’ll add a template file and a linker script to the project.

- Create Code
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Step-by-Step Procedures to Setup, Build, and Run a Demo Project
Some very simple code will be added to the template file to print a “Hello World…” 
string to a serial console connected to the evaluation board. We will use the UART 
Peripheral Library provided by Microchip.

- Build Project
The project will be built – causing the source files to be compiled and linked into 
machine code that can run on the selected PIC32 MCU.

- Test Code
Finally, the code will be tested by running it on the evaluation board.

5.5 SELECTING THE DEVICE
Choose Configure>Select Device from the top IDE menu. In the Device dialog, select 
the PIC32 variant from the drop-down list.

FIGURE 5-2: MPLAB IDE SELECT DEVICE

The “lights” indicate which MPLAB IDE components support this device.
- A green light indicates full support.
- A yellow light indicates preliminary support for an upcoming part by the 

particular MPLAB IDE tool component. Components with a yellow light 
instead of a green light are often intended for early adopters of new parts 
who need quick support and understand that some operations or functions 
may not be available.

- A red light indicates no support for this device. Support may be forthcoming or 
inappropriate for the tool.

Note: Some aspects of the user interface will change in future product releases 
and the screen shots in this guide may not exactly match the appearance 
of the MPLAB IDE desktop in later releases.
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Getting Started with PIC32
5.6 CREATING THE PROJECT
The next step is to create a project using the Project Wizard. A project is the way the 
files are organized to be compiled, assembled and linked. We will use a single “C” file 
for this project and a linker script.
Choose Project>Project Wizard.
From the Welcome dialog, click on Next> to advance.
The Step One dialog allows you to select the device, which we’ve already done. Make 
sure that it displays the proper PIC32 variant. If not, select the required PIC32 variant 
from the drop down menu. Click Next>.

FIGURE 5-3: MPLAB IDE WIZARD SELECT DEVICE
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Step-by-Step Procedures to Setup, Build, and Run a Demo Project
5.7 SETTING UP LANGUAGE TOOLS
Step Two of the Project Wizard sets up the language tools that are used with this 
project. Make sure the “Show all installed toolsuites” checkbox is checked. Select 
Microchip PIC32 C Compiler Toolsuite in the Active Toolsuite list box.
Then “MPLAB PIC32 Assembler (PIC32-as.exe)”,  “MPLAB PIC32 C Compiler 
(PIC32-gcc.exe)”, “MPLAB PIC32 Object Linker (PIC32-ld.exe)”, and “MPLAB PIC32 
Archiver (PIC32-ar.exe)”, should be visible in the Toolsuite Contents box. Click on each 
one to see its location. If MPLAB IDE was installed into the default directory, the paths 
for these files will be:
• for the MPLAB PIC32 assembler:
- C:\Program Files\Microchip\MPLAB IDE\ MPLAB 
C32\bin\PIC32-as.exe

• for the MPLAB PIC32 compiler:
- C:\Program Files\Microchip\MPLAB IDE\ MPLAB C32\bin\ 
PIC32-gcc.exe

• for the MPLAB PIC32 Object Linker:
- C:\Program Files\Microchip\MPLAB IDE\ MPLAB 
C32\bin\PIC32-ld.exe

• for the MPLAB PIC32 Archiver:
- C:\Program Files\Microchip\MPLAB IDE\ MPLAB 
C32\bin\PIC32-ar.exe

If these paths do not show up correctly, use the Browse button to set them to the proper 
files in the MPLAB IDE subfolders.
When you are finished, click Next>.

FIGURE 5-4: MPLAB IDE SELECT LANGUAGE TOOLSUITE
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Getting Started with PIC32
5.8 NAMING THE PROJECT
Step Three of the wizard allows you to name the project and put it into a folder. This 
sample project will be called MyTestProject. Using the Browse button, place the project 
in a folder named Projects32. Click Next>.

FIGURE 5-5: MPLAB IDE NAMING THE PROJECT
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Step-by-Step Procedures to Setup, Build, and Run a Demo Project
5.9 ADDING FILES TO THE PROJECT
Step Four of the Project Wizard allows file selection for the project. This is where we 
can add existing files to our project. In the current example we don’t have a previously 
created file but we’ll create one once we’re done with the new project setting.
Just press Next> and the following Summary Screen will show up:

FIGURE 5-6: MPLAB IDE SUMMARY SCREEN

Press Finish and the workspace dialog shows up:

FIGURE 5-7: MPLAB IDE SAVE WORKSPACE
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Step-by-Step Procedures to Setup, Build, and Run a Demo Project
FIGURE 5-9: MPLAB IDE MAIN.C FILE

To add the newly created main.c file to our project just right click on the Source Files 
folder in the MPLAB IDE MyTestProject.mcp window and select Add File. Browse and 
select main.c file from the Projects32 directory.

The linker script that’s needed for this project is selected automatically by the MPLAB 
IDE. We don’t need to add any other file to our project.

Note: If the Project window is not open, select View->Project from the top IDE 
menu.
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Getting Started with PIC32
Right click on MyTestProject.mcp window and select Save. The test project should be 
saved. The MyTestProject.mcp should look like:

FIGURE 5-10: MPLAB IDE PROJECT SAVED

TIP: Files can be added and projects saved by using the right mouse button in the 
project window. In case of error, files can be manually deleted by selecting them and 
using the right mouse click menu.
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