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What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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Note the following details of the code protection feature on Microchip devices:
• Microchip products meet the specification contained in their particular Microchip Data Sheet.

• Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the 
intended manner and under normal conditions.

• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our 
knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data 
Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not 
mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our
products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts
allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.
Information contained in this publication regarding device
applications and the like is provided only for your convenience
and may be superseded by updates. It is your responsibility to
ensure that your application meets with your specifications.
MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR
IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION,
QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability
arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at
the buyer’s risk, and the buyer agrees to defend, indemnify and
hold harmless Microchip from any and all damages, claims,
suits, or expenses resulting from such use. No licenses are
conveyed, implicitly or otherwise, under any Microchip
intellectual property rights.
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PIC32MX STARTER KIT
USER’S GUIDE
Preface
INTRODUCTION
This chapter contains general information that will be useful to know before using the 
PIC32MX. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document describes how to use the PIC32MX Starter Kit as a development tool to 
emulate and debug firmware on a target board. The manual is composed of the follow-
ing chapters:
• Chapter 1. “Introducing the PIC32MX Starter Kit” provides a brief overview of 

the PIC32MX Starter Kit, highlighting its features and uses.
• Chapter 2. “PIC32MX Starter Kit Tutorial” provides step-by-step instructions for 

installing the PIC32MX and using the Microchip MPLAB® IDE to build and run the 
tutorial program on the PIC32MX Starter Kit.

• Chapter 3. “Create a New Project” provides step-by-step instructions for creating 
a new project using the MPLAB IDE and loading it onto the PIC32MX Starter Kit.

• Chapter 4. “PIC32MX Starter Kit Hardware” provides a more detailed 
description of the features of the hardware included in the PIC32MX Starter Kit.

• Appendix A. “PIC32MX Starter Kit Schematics” provides a block diagram and 
detailed schematics of the PIC32MX Starter Kit. 

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
© 2009 Microchip Technology Inc. DS61144D-page 1
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DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE
Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.
To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.
The Development Systems product group categories are:
• Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C18 and MPLAB C30 C compilers, and MPLAB 
C Compiler for PIC32 compilers; ASM32, MPASM™ and MPLAB ASM30 assem-
blers; MPLINK™, and MPLAB LINK30, MPLAB LINK32 object linkers; and 
MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators. This 
includes the MPLAB REAL ICE™ and MPLAB ICE 2000 in-circuit emulators.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debuggers. This includes the MPLAB ICD 2 and PICkit™ 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB IDE Project Manager, MPLAB Editor and 
MPLAB SIM simulator, as well as general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 device programmer and the PICSTART® Plus, PICkit™ 1 and 
PICkit 2 development programmers.

CUSTOMER SUPPORT
Several channels are available to assist the users of Microchip products:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
• Development Systems Information Line
Customers should contact their distributor, representative or FAE for support. Local 
sales offices are also available to help customers. A list of sales offices and locations 
is included in the back of this document.
Technical support is available through the web site http://support.microchip.com.
DS61144D-page 4 © 2009 Microchip Technology Inc.

http://www.microchip.com
http://support.microchip.com


PIC32MX STARTER KIT
USER’S GUIDE
Chapter 1.  Introducing the PIC32MX Starter Kit
1.1 INTRODUCTION
Thank you for purchasing the Microchip Technology PIC32MX Starter Kit. This kit 
provides a low-cost, modular development system for Microchip’s new line of 32-bit 
microcontrollers. 
The starter kit comes pre-loaded with demonstration software for the user to explore 
the new features of the PIC32MX. It is also expandable through a modular expansion 
interface, which allows the user to extend its functionality. The PIC32MX Starter Kit also 
supplies on-board circuitry for full debug and programming capabilities.

1.2 HIGHLIGHTS
This chapter covers the following topics:
• Kit Contents
• PIC32MX Functionality and Features
• Installing the PIC32MX Starter Kit CD
• Using the PIC32MX Starter Kit Out of the Box
• PIC32MX Demonstration Program
The preprogrammed example code on the PIC32MX MCU has been included on the 
PIC32MX Starter Kit CD-ROM for future reference. All project files have been included, 
so that the code may be used directly to restore the PIC32MX MCU on the starter kit 
to its original state (i.e., if the sample device has been reprogrammed with another 
program), or so you can use the tutorial code as a platform for further experimentation.

1.3 KIT CONTENTS
The PIC32MX Starter Kit contains the following items:
• PIC32MX Starter Kit Board
• USB Mini-B cable
• PIC32 Starter Kit Installation CD-ROM, which includes:

- PIC32MX Starter Kit User’s Guide (DS61144)
- PIC32MX Family Data Sheet (DS61143)
- PIC32MX Family Reference Manual (DS61132)
- PIC32MX Peripheral Library Manual
- Code examples for use with the PIC32MX devices

If you are missing any part of the kit, contact a Microchip sales office for assistance. A 
list of Microchip offices for sales and service is provided on page 44.
© 2009 Microchip Technology Inc. DS61144D-page 7



Introducing the PIC32MX Starter Kit
1.5 INSTALLING THE PIC32MX STARTER KIT CD
The default PIC32MX Starter Kit installation directory is:
 c:\Microchip Starter Kits\PIC32 Starter Kits 
Note, throughout this document, the following phrase “[install directory]” refers 
to this default installation,  c:\Microchip Starter Kits, or a directory selected by the 
user during the time of installation.
The starter kit CD-ROM contains the MPLAB IDE, MPLAB C32 C Compiler tools, code 
examples, sample projects, technical documentation, a getting started tutorial, and this 
PIC32MX Starter Kit User’s Guide. When the CD is placed into your CD drive, an 
automatic installation application will guide you to install the tools and relevant 
documents. 

1.6 USING THE PIC32MX STARTER KIT OUT OF THE BOX
The PIC32MX Starter Kit may be used directly from the box as a demonstration board 
for the PIC32MX device. The PIC32MX is preprogrammed with the classic “Simon 
Says” game (simon_says_demo.hex) in the PIC32MX360F512L device and is ready 
for immediate use.

1.6.1 How to Play the Game
When the USB cable is plugged into the starter kit, the three LEDs start blinking to 
indicate the start of a new game. Begin the game by pressing one of the switches, 
SW1-SW3, to choose the level of game difficulty. SW3 is the easiest, SW1 is the 
hardest. The goal is to imitate the light patterns as long as you can, without getting 
frazzled. Ultimately, you will make a mistake and all of the LEDs will light up to signal 
the end of a game. After a brief pause, you can press a switch again to start a new 
game.
If the starter kit is connected to the MPLAB IDE, the game stops. It will be replaced by 
the MPLAB IDE project that you select when the program button is pressed. The game 
can be reloaded onto the starter kit by opening simon_says_demo.mcw from the 
following directory: 
[install directory]\PIC32 Starter Kits\simon_says_demo

1.7 PIC32MX DEMONSTRATION PROGRAM
The preprogrammed example code on the PIC32MX has been included as part of the 
PIC32MX Starter Kit installation. All project files have been included, so that the code 
may be used directly to restore a PIC32MX to its original state (i.e., if the sample device 
has been reprogrammed with another program) or so you can use the tutorial code as 
a platform for further experimentation.
© 2009 Microchip Technology Inc. DS61144D-page 9
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Chapter 2.  PIC32MX Starter Kit Tutorial 
2.1 INTRODUCTION
This chapter is a self-paced tutorial to get you started using the PIC32MX Starter Kit.

2.2 HIGHLIGHTS
Items discussed in this chapter include:
• Host Computer Requirements
• Installing the Starter Kit Board
• Starting with the Tutorial Project
• Building the Project
• Programming the Device
• Running the Program 
• Operation of the Tutorial Program 

2.3 HOST COMPUTER REQUIREMENTS
To communicate with and program the starter kit board, the following hardware and 
software requirements must be met:
• PC-compatible system 
• An available USB port on PC or powered USB hub
• CD-ROM drive
•  Microsoft Windows XP® 

(The PIC32MX Starter Kit has not been tested on Windows NT®, Windows 2000® 
or Microsoft Vista™ operating systems)
© 2009 Microchip Technology Inc. DS61144D-page 11
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2.4 INSTALLING THE STARTER KIT BOARD
As a USB device, the starter kit board requires very little effort to install; most of the 
work is done by the operating system. Begin by closing all applications.

2.4.1 Install the Tools and Projects
1. Insert the PIC32 Starter Kit CD into your CD-ROM drive and click the install from 

CD menu option. If the installation application does not automatically start, 
navigate to the files on the CD and open setup.exe. 
The following window is displayed:

FIGURE 2-1: INSTALLING THE PIC32 STARTER KIT BOARD

2. Reboot your system when prompted to do so.

Note: The dialog also provides an option to check the Microchip web site for 
newer versions of the starter kit software. 
DS61144D-page 12 © 2009 Microchip Technology Inc.
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2.5 STARTING THE TUTORIAL PROJECT
Click the MPLAB IDE icon on your computer desktop. The MPLAB IDE opens with the 
starter kit tutorial project loaded, as shown in Figure 2-7. If the MPLAB IDE does not 
have the starter kit tutorial project loaded, select File>Open Workspace... from the 
menu bar and browse to the tutorial project file:
[install directory]\PIC32 Starter Kits\ 
Starter_Kit_Tutorial\starter_kit_tutorial.mcw
(or browse to the file path you used when you installed the MPLAB IDE).
The pane on the left of the MPLAB IDE interface displays project files, the ‘.c’, ‘.h’ and 
‘.a’ files that are used to build an application. The project files are organized by type 
into folders.
“Starter Kit Found” should be displayed in the “Output” pane of the MPLAB IDE inter-
face. If you do not see this message, select Debugger>Select Tool>PIC32MX Starter 
Kit from the menu bar. If that sequence fails to find the project, check the driver 
installation, as well as the connections between the hardware and the PC. 

FIGURE 2-7: MPLAB® IDE WORKSPACE 
DS61144D-page 16 © 2009 Microchip Technology Inc.
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2.6 BUILDING THE PROJECT
From the menu bar of the main MPLAB IDE window, click Project>Make. The build 
Output window displays, as shown in Figure 2-8.
Observe the progress of the build. When the “BUILD SUCCEEDED” message displays, 
you are ready to program the device.

FIGURE 2-8: BUILD OUTPUT WINDOW
© 2009 Microchip Technology Inc. DS61144D-page 17
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Chapter 3.  Create a New Project
3.1 INTRODUCTION
This chapter explains how to create a new project. 

3.2 HIGHLIGHTS
Items discussed in this chapter include:
• Creating a New Project
• Building the Project
• Programming the Device
• Running the Program 
After completing this chapter, you should be able to accomplish the following tasks:
• Create a project using the Project Wizard
• Assemble and link the code, and set the Configuration bits
• Set up the MPLAB IDE to use the PIC32MX Starter Kit
• Program the chip, and run the program

3.3 CREATING A NEW PROJECT
The first step is to create a project and a workspace in the MPLAB IDE. Typically, there 
is a single project per workspace.
A project contains the files needed to build an application (i.e., source code, header 
files, library, etc.), and their corresponding build options.
A workspace contains one or more projects, information on the selected device, 
debug/programmer tool, and MPLAB IDE configuration settings.
MPLAB IDE contains a Project Wizard to help create a new project. 
You will perform the following tasks as you create a new project:
Task 1, Select a Device ..................................................... page 24
Task 2, Select the Language Toolsuite ............................ page 25
Task 3, Name Your Project ................................................ page 26
Task 4, Add Files to Your Project ..................................... page 27
Task 5, Confirm the Configuration Settings .................... page 30
Task 6, Build the Project .................................................. page 31
Task 7, Program the Device .............................................. page 32
Task 8, Run the Program ................................................... page 33
© 2009 Microchip Technology Inc. DS61144D-page 23
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3.3.1 Task 1, Select a Device
1. Start MPLAB IDE.
2. Click File>Close Workspace on the menu bar, to close any workspace that is 

open. 
3. Click Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is 

displayed, as shown in Figure 3-1. 

FIGURE 3-1: SELECTING THE DEVICE

5. From the “Device” drop-down list, select “PIC32MX360F512L”. 
6. Click Next. The Project Wizard Step Two: dialog box opens, as shown in 

Figure 3-2.
DS61144D-page 24 © 2009 Microchip Technology Inc.
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FIGURE 3-2: SELECTING THE TOOLSUITE

3.3.2 Task 2, Select the Language Toolsuite
1. From the “Active Toolsuite” drop-down list, click “Microchip PIC32 C Compiler 

Toolsuite”. The toolsuite includes the assembler and linker that will be used. If the 
PIC32 compiler option is not available, check the “show all installed toolsuites” 
box.

2. Click Next to continue. The Project Wizard Step Three: dialog opens, as shown 
in Figure 3-3.
© 2009 Microchip Technology Inc. DS61144D-page 25
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FIGURE 3-3: NAMING YOUR PROJECT

3.3.3 Task 3, Name Your Project
1. In the “Create New Project File” field, type C:\MyProject\BlinkLED.
2. Click Next and Ok to continue. The Project Wizard Step Four: dialog opens, as 

shown in Figure 3-4.
DS61144D-page 26 © 2009 Microchip Technology Inc.
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3.3.5 Task 5, Confirm the Configuration Settings
Click Configure>Configuration Bits to confirm that the configuration settings are cor-
rect. Typical configuration settings for the starter kit are shown in Figure 3-6. 

FIGURE 3-6: CONFIGURATION BIT SETTINGS 

Note: The “Configuration Bits set in code” check box must be unchecked if the 
config bits are set via this window and not in the code.
The configuration settings can also be embedded in the source file. 
See the MPLAB C Compiler for PIC32 User’s Guide (DS51686) for  
information.

CAUTION

Setting the PIC32 Starter Kit configuration bits to cause the PIC32MX to oper-
ate faster than the maximum 80MHz system clock speed may cause the 
PIC32MX to stop communicating with the PIC18F4550 Starter Kit debugger. 
Should this occur, run the sk_erase.exe utility to re-flash the PIC32MX with a 
default configuration. This utility is located on the PIC32 Starter Kit CD or in 
the PIC32MX Starter Kit directory:
[install directory]\PIC32 Starter Kits\tools
DS61144D-page 30 © 2009 Microchip Technology Inc.
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Appendix A. PIC32MX Starter Kit Schematics
A.1 INTRODUCTION
This section provides detailed technical information about the PIC32MX Starter Kit.

A.2 DEVELOPMENT BOARD BLOCK DIAGRAM

FIGURE A-1: HIGH-LEVEL BLOCK DIAGRAM OF THE PIC32MX STARTER KIT

A.3 STARTER KIT BOARD SCHEMATICS
Figure A-2. PIC32MX CPU
Figure A-3. PIC18LF4550 Debug CPU
Figure A-4. Application Board Connector
Figure A-5. Switches and LEDs
Figure A-6. Power Supply
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FIGURE A-6: PIC32MX SCHEMATIC, SHEET 6 OF 6 (POWER SUPPLY)
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Tel: 905-673-0699  
Fax:  905-673-6509

ASIA/PACIFIC
Asia Pacific Office
Suites 3707-14, 37th Floor
Tower 6, The Gateway
Harbour City, Kowloon
Hong Kong
Tel: 852-2401-1200
Fax: 852-2401-3431
Australia - Sydney
Tel: 61-2-9868-6733
Fax: 61-2-9868-6755
China - Beijing
Tel: 86-10-8528-2100 
Fax: 86-10-8528-2104
China - Chengdu
Tel: 86-28-8665-5511
Fax: 86-28-8665-7889
China - Hong Kong SAR
Tel: 852-2401-1200  
Fax: 852-2401-3431
China - Nanjing
Tel: 86-25-8473-2460
Fax: 86-25-8473-2470
China - Qingdao
Tel: 86-532-8502-7355
Fax: 86-532-8502-7205
China - Shanghai
Tel: 86-21-5407-5533  
Fax: 86-21-5407-5066
China - Shenyang
Tel: 86-24-2334-2829
Fax: 86-24-2334-2393
China - Shenzhen
Tel: 86-755-8203-2660 
Fax: 86-755-8203-1760
China - Wuhan
Tel: 86-27-5980-5300
Fax: 86-27-5980-5118
China - Xiamen
Tel: 86-592-2388138 
Fax: 86-592-2388130
China - Xian
Tel: 86-29-8833-7252
Fax: 86-29-8833-7256
China - Zhuhai
Tel: 86-756-3210040 
Fax: 86-756-3210049

ASIA/PACIFIC
India - Bangalore
Tel: 91-80-3090-4444 
Fax: 91-80-3090-4080
India - New Delhi
Tel: 91-11-4160-8631
Fax: 91-11-4160-8632
India - Pune
Tel: 91-20-2566-1512
Fax: 91-20-2566-1513
Japan - Yokohama
Tel: 81-45-471- 6166  
Fax: 81-45-471-6122
Korea - Daegu
Tel: 82-53-744-4301
Fax: 82-53-744-4302
Korea - Seoul
Tel: 82-2-554-7200
Fax: 82-2-558-5932 or 
82-2-558-5934
Malaysia - Kuala Lumpur
Tel: 60-3-6201-9857
Fax: 60-3-6201-9859
Malaysia - Penang
Tel: 60-4-227-8870
Fax: 60-4-227-4068
Philippines - Manila
Tel: 63-2-634-9065
Fax: 63-2-634-9069
Singapore
Tel:  65-6334-8870
Fax: 65-6334-8850
Taiwan - Hsin Chu
Tel: 886-3-572-9526
Fax: 886-3-572-6459
Taiwan - Kaohsiung
Tel: 886-7-536-4818
Fax: 886-7-536-4803
Taiwan - Taipei
Tel: 886-2-2500-6610  
Fax: 886-2-2508-0102
Thailand - Bangkok
Tel: 66-2-694-1351
Fax: 66-2-694-1350

EUROPE
Austria - Wels
Tel: 43-7242-2244-39
Fax: 43-7242-2244-393
Denmark - Copenhagen
Tel: 45-4450-2828 
Fax: 45-4485-2829
France - Paris
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-30-90-79
Germany - Munich
Tel: 49-89-627-144-0 
Fax: 49-89-627-144-44
Italy - Milan 
Tel: 39-0331-742611  
Fax: 39-0331-466781
Netherlands - Drunen
Tel: 31-416-690399 
Fax: 31-416-690340
Spain - Madrid
Tel: 34-91-708-08-90
Fax: 34-91-708-08-91
UK - Wokingham
Tel: 44-118-921-5869
Fax: 44-118-921-5820

WORLDWIDE SALES AND SERVICE
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