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Welcome to E-XFL.COM

What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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PIC32MX STARTER KIT
USER’S GUIDE
Preface
INTRODUCTION
This chapter contains general information that will be useful to know before using the 
PIC32MX. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document describes how to use the PIC32MX Starter Kit as a development tool to 
emulate and debug firmware on a target board. The manual is composed of the follow-
ing chapters:
• Chapter 1. “Introducing the PIC32MX Starter Kit” provides a brief overview of 

the PIC32MX Starter Kit, highlighting its features and uses.
• Chapter 2. “PIC32MX Starter Kit Tutorial” provides step-by-step instructions for 

installing the PIC32MX and using the Microchip MPLAB® IDE to build and run the 
tutorial program on the PIC32MX Starter Kit.

• Chapter 3. “Create a New Project” provides step-by-step instructions for creating 
a new project using the MPLAB IDE and loading it onto the PIC32MX Starter Kit.

• Chapter 4. “PIC32MX Starter Kit Hardware” provides a more detailed 
description of the features of the hardware included in the PIC32MX Starter Kit.

• Appendix A. “PIC32MX Starter Kit Schematics” provides a block diagram and 
detailed schematics of the PIC32MX Starter Kit. 

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
© 2009 Microchip Technology Inc. DS61144D-page 1



Preface
DOCUMENT REVISION HISTORY 

Revision A (October 2007)
This is the initial release of the PIC32MX Starter Kit User’s Guide.

Revision B (October 2007)
Removed confidential status.

Revision C (November 2008)
Updated the instructions in Section 3.3.2 “Task 2, Select the Language Toolsuite”.
Added connector table in Section Table 4-1: “Starter Board Connector Part 
Numbers”.

Revision D (February 2009)
Updated directory names and associated figures.
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PIC32MX STARTER KIT
USER’S GUIDE
Chapter 1.  Introducing the PIC32MX Starter Kit
1.1 INTRODUCTION
Thank you for purchasing the Microchip Technology PIC32MX Starter Kit. This kit 
provides a low-cost, modular development system for Microchip’s new line of 32-bit 
microcontrollers. 
The starter kit comes pre-loaded with demonstration software for the user to explore 
the new features of the PIC32MX. It is also expandable through a modular expansion 
interface, which allows the user to extend its functionality. The PIC32MX Starter Kit also 
supplies on-board circuitry for full debug and programming capabilities.

1.2 HIGHLIGHTS
This chapter covers the following topics:
• Kit Contents
• PIC32MX Functionality and Features
• Installing the PIC32MX Starter Kit CD
• Using the PIC32MX Starter Kit Out of the Box
• PIC32MX Demonstration Program
The preprogrammed example code on the PIC32MX MCU has been included on the 
PIC32MX Starter Kit CD-ROM for future reference. All project files have been included, 
so that the code may be used directly to restore the PIC32MX MCU on the starter kit 
to its original state (i.e., if the sample device has been reprogrammed with another 
program), or so you can use the tutorial code as a platform for further experimentation.

1.3 KIT CONTENTS
The PIC32MX Starter Kit contains the following items:
• PIC32MX Starter Kit Board
• USB Mini-B cable
• PIC32 Starter Kit Installation CD-ROM, which includes:

- PIC32MX Starter Kit User’s Guide (DS61144)
- PIC32MX Family Data Sheet (DS61143)
- PIC32MX Family Reference Manual (DS61132)
- PIC32MX Peripheral Library Manual
- Code examples for use with the PIC32MX devices

If you are missing any part of the kit, contact a Microchip sales office for assistance. A 
list of Microchip offices for sales and service is provided on page 44.
© 2009 Microchip Technology Inc. DS61144D-page 7
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PIC32MX STARTER KIT
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Chapter 2.  PIC32MX Starter Kit Tutorial 
2.1 INTRODUCTION
This chapter is a self-paced tutorial to get you started using the PIC32MX Starter Kit.

2.2 HIGHLIGHTS
Items discussed in this chapter include:
• Host Computer Requirements
• Installing the Starter Kit Board
• Starting with the Tutorial Project
• Building the Project
• Programming the Device
• Running the Program 
• Operation of the Tutorial Program 

2.3 HOST COMPUTER REQUIREMENTS
To communicate with and program the starter kit board, the following hardware and 
software requirements must be met:
• PC-compatible system 
• An available USB port on PC or powered USB hub
• CD-ROM drive
•  Microsoft Windows XP® 

(The PIC32MX Starter Kit has not been tested on Windows NT®, Windows 2000® 
or Microsoft Vista™ operating systems)
© 2009 Microchip Technology Inc. DS61144D-page 11



PIC32MX Starter Kit Tutorial
2.4.2 View the Getting Started Tutorial
Perform the following steps to view the tutorial:
1. After your computer has rebooted, the Getting Started Tutorial menu opens. 
2. View the tutorial instructions for connecting to the starter kit board and running 

the tutorial project.
If you performed the installation steps as you followed along in the Getting Started 
tutorial, skip to Section 2.5 “Starting the Tutorial Project” on page 16.
If you did not, continue to the next page for instructions about how to connect the board 
and install the device driver.

2.4.3 Connect the Starter Kit Board
Using the supplied USB cable, connect the board to an open USB port on your com-
puter. (A USB hub that is not bus-powered can also be used.) Connect the other end 
of the cable into the USB connector on the starter kit board.
Check the board: the green power LED D3 should be lit. If it is not, check the 
connections at the port, hub, and board.

2.4.4 Install the USB Device Driver

Perform the following steps to install the USB device driver:
1. When the USB cable is connected, the “Found New Hardware Wizard” dialog 

box opens, as shown in Figure 2-2. When asked whether to install the software 
automatically or install from a list or specific location, select “Install software 
automatically” and click Next. 

FIGURE 2-2: FOUND NEW HARDWARE WIZARD 

Note: The USB driver installation steps described here refer specifically to 
installing the driver on a Microsoft Windows XP operating system.
© 2009 Microchip Technology Inc. DS61144D-page 13



PIC32MX Starter Kit Tutorial
4. If prompted with a dialog box for Windows Logo testing, as shown in Figure 2-5, 
click Continue Anyway.

FIGURE 2-5: WINDOWS LOGO TESTING 

5. The next window (Figure 2-6) indicates that the installation of the software for the 
starter kit is complete. Click Finish.

FIGURE 2-6: COMPLETING DEVICE DRIVER INSTALLATION
© 2009 Microchip Technology Inc. DS61144D-page 15
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2.7 PROGRAMMING THE DEVICE

2.7.1 Program the Device
Click on the Program All Memories icon on the Program Device Tool Bar, as shown in 
Figure 2-9).

FIGURE 2-9: PROGRAM DEVICE TOOL BAR

A Programming Warning window (Figure 2-10) opens to warn you about overwriting 
the memory. Click Yes. 

FIGURE 2-10: PROGRAMMING WARNING WINDOW

The Output window (Figure 2-11) tracks the progress of the output. A “Done” entry 
indicates that the programming of the device is complete.

FIGURE 2-11: OUTPUT WINDOW
DS61144D-page 18 © 2009 Microchip Technology Inc.
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2.8 RUNNING THE PROGRAM
Either click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon 
(the turquoise triangle) on the Debug Tool Bar (Figure 2-12) to run the new program. 

FIGURE 2-12: DEBUG WINDOW

2.9 TUTORIAL PROGRAM OPERATION
The starter kit tutorial demonstrates a simple application. The program responds 
according to the user input menu. The program prints the available menu choices to 
the starter kit Output window in the MPLAB IDE. The program flow is shown in 
Figure 2-13.
© 2009 Microchip Technology Inc. DS61144D-page 19
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FIGURE 2-13: PIC32MX TUTORIAL PROGRAM FLOWCHART
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Chapter 3.  Create a New Project
3.1 INTRODUCTION
This chapter explains how to create a new project. 

3.2 HIGHLIGHTS
Items discussed in this chapter include:
• Creating a New Project
• Building the Project
• Programming the Device
• Running the Program 
After completing this chapter, you should be able to accomplish the following tasks:
• Create a project using the Project Wizard
• Assemble and link the code, and set the Configuration bits
• Set up the MPLAB IDE to use the PIC32MX Starter Kit
• Program the chip, and run the program

3.3 CREATING A NEW PROJECT
The first step is to create a project and a workspace in the MPLAB IDE. Typically, there 
is a single project per workspace.
A project contains the files needed to build an application (i.e., source code, header 
files, library, etc.), and their corresponding build options.
A workspace contains one or more projects, information on the selected device, 
debug/programmer tool, and MPLAB IDE configuration settings.
MPLAB IDE contains a Project Wizard to help create a new project. 
You will perform the following tasks as you create a new project:
Task 1, Select a Device ..................................................... page 24
Task 2, Select the Language Toolsuite ............................ page 25
Task 3, Name Your Project ................................................ page 26
Task 4, Add Files to Your Project ..................................... page 27
Task 5, Confirm the Configuration Settings .................... page 30
Task 6, Build the Project .................................................. page 31
Task 7, Program the Device .............................................. page 32
Task 8, Run the Program ................................................... page 33
© 2009 Microchip Technology Inc. DS61144D-page 23
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3.3.1 Task 1, Select a Device
1. Start MPLAB IDE.
2. Click File>Close Workspace on the menu bar, to close any workspace that is 

open. 
3. Click Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is 

displayed, as shown in Figure 3-1. 

FIGURE 3-1: SELECTING THE DEVICE

5. From the “Device” drop-down list, select “PIC32MX360F512L”. 
6. Click Next. The Project Wizard Step Two: dialog box opens, as shown in 

Figure 3-2.
DS61144D-page 24 © 2009 Microchip Technology Inc.
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FIGURE 3-3: NAMING YOUR PROJECT

3.3.3 Task 3, Name Your Project
1. In the “Create New Project File” field, type C:\MyProject\BlinkLED.
2. Click Next and Ok to continue. The Project Wizard Step Four: dialog opens, as 

shown in Figure 3-4.
DS61144D-page 26 © 2009 Microchip Technology Inc.



Create a New Project
FIGURE 3-4: ADDING FILES TO THE PROJECT 

3.3.4 Task 4, Add Files to Your Project
This window can be skipped, since no ‘.c’ files have been created. 
1. Click Next to continue. 
2. Click Finish on the summary screen.
3. A project and workspace have been created in the MPLAB IDE. 

BlinkLED.mcw is the workspace file and BlinkLED.mcp is the project file. 
4. Click File>New from the menu bar to create a new file. A new file is displayed. 
5. Click File>Save As... and save this file as ‘BlinkLED.c’ in the same folder (in this 

case, the C:\MyProject folder). 
6. Now copy the source code provided in Example 3-1 to the BlinkLED.c file. The 

source code file is located in the PIC32 Starter Kit directory: 
[install directory]\PIC32 Starter Kits\Blink_Leds.
© 2009 Microchip Technology Inc. DS61144D-page 27



Create a New Project
7. In the Project window, right-click on the Source Files folder. Select Add Files and 
choose BlinkLED.c to add the file to the source directory, as shown in 
Figure 3-5. 

FIGURE 3-5: ADDING SOURCE FILES 

8. Click Debugger>Select Tool>PIC32MX Starter Kit from the menu bar, for the 
Target board. 

Note: Make sure that the starter kit demo board is connected to your PC.
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3.3.5 Task 5, Confirm the Configuration Settings
Click Configure>Configuration Bits to confirm that the configuration settings are cor-
rect. Typical configuration settings for the starter kit are shown in Figure 3-6. 

FIGURE 3-6: CONFIGURATION BIT SETTINGS 

Note: The “Configuration Bits set in code” check box must be unchecked if the 
config bits are set via this window and not in the code.
The configuration settings can also be embedded in the source file. 
See the MPLAB C Compiler for PIC32 User’s Guide (DS51686) for  
information.

CAUTION

Setting the PIC32 Starter Kit configuration bits to cause the PIC32MX to oper-
ate faster than the maximum 80MHz system clock speed may cause the 
PIC32MX to stop communicating with the PIC18F4550 Starter Kit debugger. 
Should this occur, run the sk_erase.exe utility to re-flash the PIC32MX with a 
default configuration. This utility is located on the PIC32 Starter Kit CD or in 
the PIC32MX Starter Kit directory:
[install directory]\PIC32 Starter Kits\tools
DS61144D-page 30 © 2009 Microchip Technology Inc.
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3.3.7 Task 7, Program the Device
1. Click the Program All Memories icon on the Program Device Tool Bar, as shown 

in Figure 3-8.

FIGURE 3-8: PROGRAM DEVICE WINDOW

A Programming Warning window (Figure 3-9) opens to warn you about overwriting the 
memory. 
2. Click Yes. 

FIGURE 3-9: PROGRAMMING WARNING WINDOW

The Output window (Figure 3-10) tracks the progress of the output. “Done” signals that 
the programming of the device is complete.

FIGURE 3-10: OUTPUT WINDOW
DS61144D-page 32 © 2009 Microchip Technology Inc.



Create a New Project
3.3.8 Task 8, Run the Program
Click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon (the 
turquoise triangle) on the Debug Tool Bar, as indicated in Figure 3-11, to run the new 
program. 

FIGURE 3-11: RUN THE PROGRAM

The starter kit LEDs blink to indicate that the program is running successfully. 
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FIGURE A-6: PIC32MX SCHEMATIC, SHEET 6 OF 6 (POWER SUPPLY)
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