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What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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Note the following details of the code protection feature on Microchip devices:
• Microchip products meet the specification contained in their particular Microchip Data Sheet.

• Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the 
intended manner and under normal conditions.

• There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our 
knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data 
Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

• Microchip is willing to work with the customer who is concerned about the integrity of their code.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not 
mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our
products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts
allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.
Information contained in this publication regarding device
applications and the like is provided only for your convenience
and may be superseded by updates. It is your responsibility to
ensure that your application meets with your specifications.
MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR
IMPLIED, WRITTEN OR ORAL, STATUTORY OR
OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION,
QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability
arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at
the buyer’s risk, and the buyer agrees to defend, indemnify and
hold harmless Microchip from any and all damages, claims,
suits, or expenses resulting from such use. No licenses are
conveyed, implicitly or otherwise, under any Microchip
intellectual property rights.
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Introducing the PIC32MX Starter Kit
1.5 INSTALLING THE PIC32MX STARTER KIT CD
The default PIC32MX Starter Kit installation directory is:
 c:\Microchip Starter Kits\PIC32 Starter Kits 
Note, throughout this document, the following phrase “[install directory]” refers 
to this default installation,  c:\Microchip Starter Kits, or a directory selected by the 
user during the time of installation.
The starter kit CD-ROM contains the MPLAB IDE, MPLAB C32 C Compiler tools, code 
examples, sample projects, technical documentation, a getting started tutorial, and this 
PIC32MX Starter Kit User’s Guide. When the CD is placed into your CD drive, an 
automatic installation application will guide you to install the tools and relevant 
documents. 

1.6 USING THE PIC32MX STARTER KIT OUT OF THE BOX
The PIC32MX Starter Kit may be used directly from the box as a demonstration board 
for the PIC32MX device. The PIC32MX is preprogrammed with the classic “Simon 
Says” game (simon_says_demo.hex) in the PIC32MX360F512L device and is ready 
for immediate use.

1.6.1 How to Play the Game
When the USB cable is plugged into the starter kit, the three LEDs start blinking to 
indicate the start of a new game. Begin the game by pressing one of the switches, 
SW1-SW3, to choose the level of game difficulty. SW3 is the easiest, SW1 is the 
hardest. The goal is to imitate the light patterns as long as you can, without getting 
frazzled. Ultimately, you will make a mistake and all of the LEDs will light up to signal 
the end of a game. After a brief pause, you can press a switch again to start a new 
game.
If the starter kit is connected to the MPLAB IDE, the game stops. It will be replaced by 
the MPLAB IDE project that you select when the program button is pressed. The game 
can be reloaded onto the starter kit by opening simon_says_demo.mcw from the 
following directory: 
[install directory]\PIC32 Starter Kits\simon_says_demo

1.7 PIC32MX DEMONSTRATION PROGRAM
The preprogrammed example code on the PIC32MX has been included as part of the 
PIC32MX Starter Kit installation. All project files have been included, so that the code 
may be used directly to restore a PIC32MX to its original state (i.e., if the sample device 
has been reprogrammed with another program) or so you can use the tutorial code as 
a platform for further experimentation.
© 2009 Microchip Technology Inc. DS61144D-page 9



PIC32MX Starter Kit Tutorial
2.4.2 View the Getting Started Tutorial
Perform the following steps to view the tutorial:
1. After your computer has rebooted, the Getting Started Tutorial menu opens. 
2. View the tutorial instructions for connecting to the starter kit board and running 

the tutorial project.
If you performed the installation steps as you followed along in the Getting Started 
tutorial, skip to Section 2.5 “Starting the Tutorial Project” on page 16.
If you did not, continue to the next page for instructions about how to connect the board 
and install the device driver.

2.4.3 Connect the Starter Kit Board
Using the supplied USB cable, connect the board to an open USB port on your com-
puter. (A USB hub that is not bus-powered can also be used.) Connect the other end 
of the cable into the USB connector on the starter kit board.
Check the board: the green power LED D3 should be lit. If it is not, check the 
connections at the port, hub, and board.

2.4.4 Install the USB Device Driver

Perform the following steps to install the USB device driver:
1. When the USB cable is connected, the “Found New Hardware Wizard” dialog 

box opens, as shown in Figure 2-2. When asked whether to install the software 
automatically or install from a list or specific location, select “Install software 
automatically” and click Next. 

FIGURE 2-2: FOUND NEW HARDWARE WIZARD 

Note: The USB driver installation steps described here refer specifically to 
installing the driver on a Microsoft Windows XP operating system.
© 2009 Microchip Technology Inc. DS61144D-page 13



PIC32MX Starter Kit Tutorial
2.6 BUILDING THE PROJECT
From the menu bar of the main MPLAB IDE window, click Project>Make. The build 
Output window displays, as shown in Figure 2-8.
Observe the progress of the build. When the “BUILD SUCCEEDED” message displays, 
you are ready to program the device.

FIGURE 2-8: BUILD OUTPUT WINDOW
© 2009 Microchip Technology Inc. DS61144D-page 17



PIC32MX Starter Kit Tutorial
2.8 RUNNING THE PROGRAM
Either click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon 
(the turquoise triangle) on the Debug Tool Bar (Figure 2-12) to run the new program. 

FIGURE 2-12: DEBUG WINDOW

2.9 TUTORIAL PROGRAM OPERATION
The starter kit tutorial demonstrates a simple application. The program responds 
according to the user input menu. The program prints the available menu choices to 
the starter kit Output window in the MPLAB IDE. The program flow is shown in 
Figure 2-13.
© 2009 Microchip Technology Inc. DS61144D-page 19



PIC32MX Starter Kit User’s Guide
FIGURE 2-13: PIC32MX TUTORIAL PROGRAM FLOWCHART
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PIC32MX Starter Kit Tutorial
The tutorial program includes the Debug Print Library, which facilitates print functional-
ity. A peripheral library header file for flashing the LEDs is also included. The header 
file for print functionality is db_utils.h. 
Depending on the macro definition given in the print header file, the debug print macros 
will be expanded. The print functionality in the tutorial is routed to the Output window 
on the MPLAB PIC32MX tab in the interface window. In order to achieve this, the 
macro definition “PIC32_STARTER_KIT” is added to the MPLAB C Compiler for PIC32 
options.
As the program runs, the Output window (Figure 2-14) tracks the progress.

FIGURE 2-14: OUTPUT WINDOW

After printing the menu, the application displays a prompt that requests your input, see 
Figure 2-15.

FIGURE 2-15: TARGET IN WINDOW

Type your choice into the Enter Information to be Sent to Target box, and click Send. 
The program responds according to the menu entry. Watch the LEDs on the starter kit 
board. If your entry is incorrect, the LEDs will toggle once.
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Chapter 3.  Create a New Project
3.1 INTRODUCTION
This chapter explains how to create a new project. 

3.2 HIGHLIGHTS
Items discussed in this chapter include:
• Creating a New Project
• Building the Project
• Programming the Device
• Running the Program 
After completing this chapter, you should be able to accomplish the following tasks:
• Create a project using the Project Wizard
• Assemble and link the code, and set the Configuration bits
• Set up the MPLAB IDE to use the PIC32MX Starter Kit
• Program the chip, and run the program

3.3 CREATING A NEW PROJECT
The first step is to create a project and a workspace in the MPLAB IDE. Typically, there 
is a single project per workspace.
A project contains the files needed to build an application (i.e., source code, header 
files, library, etc.), and their corresponding build options.
A workspace contains one or more projects, information on the selected device, 
debug/programmer tool, and MPLAB IDE configuration settings.
MPLAB IDE contains a Project Wizard to help create a new project. 
You will perform the following tasks as you create a new project:
Task 1, Select a Device ..................................................... page 24
Task 2, Select the Language Toolsuite ............................ page 25
Task 3, Name Your Project ................................................ page 26
Task 4, Add Files to Your Project ..................................... page 27
Task 5, Confirm the Configuration Settings .................... page 30
Task 6, Build the Project .................................................. page 31
Task 7, Program the Device .............................................. page 32
Task 8, Run the Program ................................................... page 33
© 2009 Microchip Technology Inc. DS61144D-page 23



PIC32MX Starter Kit User’s Guide
3.3.1 Task 1, Select a Device
1. Start MPLAB IDE.
2. Click File>Close Workspace on the menu bar, to close any workspace that is 

open. 
3. Click Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is 

displayed, as shown in Figure 3-1. 

FIGURE 3-1: SELECTING THE DEVICE

5. From the “Device” drop-down list, select “PIC32MX360F512L”. 
6. Click Next. The Project Wizard Step Two: dialog box opens, as shown in 

Figure 3-2.
DS61144D-page 24 © 2009 Microchip Technology Inc.



PIC32MX Starter Kit User’s Guide
FIGURE 3-3: NAMING YOUR PROJECT

3.3.3 Task 3, Name Your Project
1. In the “Create New Project File” field, type C:\MyProject\BlinkLED.
2. Click Next and Ok to continue. The Project Wizard Step Four: dialog opens, as 

shown in Figure 3-4.
DS61144D-page 26 © 2009 Microchip Technology Inc.



Create a New Project
3.3.6 Task 6, Build the Project
1. Click Project>Make from the menu bar of the main MPLAB IDE window. The 

build Output window displays (Figure 3-7).
2. Observe the progress of the build. When the “BUILD SUCCEEDED” message 

displays, you are ready to program the device.

FIGURE 3-7: BUILD OUTPUT WINDOW
© 2009 Microchip Technology Inc. DS61144D-page 31



PIC32MX Starter Kit User’s Guide
3.3.7 Task 7, Program the Device
1. Click the Program All Memories icon on the Program Device Tool Bar, as shown 

in Figure 3-8.

FIGURE 3-8: PROGRAM DEVICE WINDOW

A Programming Warning window (Figure 3-9) opens to warn you about overwriting the 
memory. 
2. Click Yes. 

FIGURE 3-9: PROGRAMMING WARNING WINDOW

The Output window (Figure 3-10) tracks the progress of the output. “Done” signals that 
the programming of the device is complete.

FIGURE 3-10: OUTPUT WINDOW
DS61144D-page 32 © 2009 Microchip Technology Inc.



Create a New Project
3.3.8 Task 8, Run the Program
Click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon (the 
turquoise triangle) on the Debug Tool Bar, as indicated in Figure 3-11, to run the new 
program. 

FIGURE 3-11: RUN THE PROGRAM

The starter kit LEDs blink to indicate that the program is running successfully. 
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Chapter 4.  PIC32MX Starter Kit Hardware
4.1 INTRODUCTION
This chapter describes the hardware features of the PIC32MX Starter Kit. 

4.2 HARDWARE FEATURES
The key features of the PIC32MX Starter Kit are listed below. They are presented in the 
order given in Section 1.4 “PIC32MX Functionality and Features”. You can refer to 
Figure 1-1 on page 8 for their locations on the board.

4.2.1 Processor Support
The PIC32MX Starter Kit is designed with a permanently mounted (i.e., soldered) 
PIC32MX360F512L processor.

4.2.2 Power Supply
There are two ways to supply power to the PIC32MX Starter Kit:

• USB bus power connected to J1.
• An external application board with a regulated DC power supply that provides +5V 

can be connected to the J2 application board connector that is provided on the 
bottom side of the board.

One green LED (D3) is provided to show that the PIC32 microcontroller is powered up.

4.2.3 USB Connectivity
The PIC32MX Starter Kit includes a PIC18LF4550 USB microcontroller, which provides 
both USB connectivity and support for protocol translation. The PIC18LF4550 is 
hard-wired to the PIC32MX device to provide two types of connectivity:
• I/O pins of PIC18LF4550 to ICSP™ pins of PIC32MX
• I/O pins of PIC18LF4550 to JTAG pins of PIC32MX
The PIC32MX Starter Kit currently uses the JTAG pins of the PIC32MX device for 
programming and debugging.

Note: The basic PIC32MX Starter Kit does not include an application board and 
is intended to be USB-bus powered. 
© 2009 Microchip Technology Inc. DS61144D-page 35
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Appendix A. PIC32MX Starter Kit Schematics
A.1 INTRODUCTION
This section provides detailed technical information about the PIC32MX Starter Kit.

A.2 DEVELOPMENT BOARD BLOCK DIAGRAM

FIGURE A-1: HIGH-LEVEL BLOCK DIAGRAM OF THE PIC32MX STARTER KIT

A.3 STARTER KIT BOARD SCHEMATICS
Figure A-2. PIC32MX CPU
Figure A-3. PIC18LF4550 Debug CPU
Figure A-4. Application Board Connector
Figure A-5. Switches and LEDs
Figure A-6. Power Supply
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FIGURE A-2:PIC32MX SCHEMATIC, SHEET 1 OF 6 (PIC32MX CPU)



FIGURE A-5:  PIC32MX SCHEMATIC, SHEET 5 OF 6 (SWITCHES AND LEDS)
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FIGURE A-6: PIC32MX SCHEMATIC, SHEET 6 OF 6 (POWER SUPPLY)
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