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What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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PIC32MX STARTER KIT
USER’S GUIDE
Preface
INTRODUCTION
This chapter contains general information that will be useful to know before using the 
PIC32MX. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document describes how to use the PIC32MX Starter Kit as a development tool to 
emulate and debug firmware on a target board. The manual is composed of the follow-
ing chapters:
• Chapter 1. “Introducing the PIC32MX Starter Kit” provides a brief overview of 

the PIC32MX Starter Kit, highlighting its features and uses.
• Chapter 2. “PIC32MX Starter Kit Tutorial” provides step-by-step instructions for 

installing the PIC32MX and using the Microchip MPLAB® IDE to build and run the 
tutorial program on the PIC32MX Starter Kit.

• Chapter 3. “Create a New Project” provides step-by-step instructions for creating 
a new project using the MPLAB IDE and loading it onto the PIC32MX Starter Kit.

• Chapter 4. “PIC32MX Starter Kit Hardware” provides a more detailed 
description of the features of the hardware included in the PIC32MX Starter Kit.

• Appendix A. “PIC32MX Starter Kit Schematics” provides a block diagram and 
detailed schematics of the PIC32MX Starter Kit. 

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
© 2009 Microchip Technology Inc. DS61144D-page 1



PIC32MX Starter Kit User’s Guide
CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or dialog “Save project before build”
Underlined, italic text with right 
angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants (in source code) 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be any 
valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, var_name...]

Represents code supplied by user void main (void)
{ ...
}

DS61144D-page 2 © 2009 Microchip Technology Inc.
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Chapter 1.  Introducing the PIC32MX Starter Kit
1.1 INTRODUCTION
Thank you for purchasing the Microchip Technology PIC32MX Starter Kit. This kit 
provides a low-cost, modular development system for Microchip’s new line of 32-bit 
microcontrollers. 
The starter kit comes pre-loaded with demonstration software for the user to explore 
the new features of the PIC32MX. It is also expandable through a modular expansion 
interface, which allows the user to extend its functionality. The PIC32MX Starter Kit also 
supplies on-board circuitry for full debug and programming capabilities.

1.2 HIGHLIGHTS
This chapter covers the following topics:
• Kit Contents
• PIC32MX Functionality and Features
• Installing the PIC32MX Starter Kit CD
• Using the PIC32MX Starter Kit Out of the Box
• PIC32MX Demonstration Program
The preprogrammed example code on the PIC32MX MCU has been included on the 
PIC32MX Starter Kit CD-ROM for future reference. All project files have been included, 
so that the code may be used directly to restore the PIC32MX MCU on the starter kit 
to its original state (i.e., if the sample device has been reprogrammed with another 
program), or so you can use the tutorial code as a platform for further experimentation.

1.3 KIT CONTENTS
The PIC32MX Starter Kit contains the following items:
• PIC32MX Starter Kit Board
• USB Mini-B cable
• PIC32 Starter Kit Installation CD-ROM, which includes:

- PIC32MX Starter Kit User’s Guide (DS61144)
- PIC32MX Family Data Sheet (DS61143)
- PIC32MX Family Reference Manual (DS61132)
- PIC32MX Peripheral Library Manual
- Code examples for use with the PIC32MX devices

If you are missing any part of the kit, contact a Microchip sales office for assistance. A 
list of Microchip offices for sales and service is provided on page 44.
© 2009 Microchip Technology Inc. DS61144D-page 7
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NOTES:
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Chapter 2.  PIC32MX Starter Kit Tutorial 
2.1 INTRODUCTION
This chapter is a self-paced tutorial to get you started using the PIC32MX Starter Kit.

2.2 HIGHLIGHTS
Items discussed in this chapter include:
• Host Computer Requirements
• Installing the Starter Kit Board
• Starting with the Tutorial Project
• Building the Project
• Programming the Device
• Running the Program 
• Operation of the Tutorial Program 

2.3 HOST COMPUTER REQUIREMENTS
To communicate with and program the starter kit board, the following hardware and 
software requirements must be met:
• PC-compatible system 
• An available USB port on PC or powered USB hub
• CD-ROM drive
•  Microsoft Windows XP® 

(The PIC32MX Starter Kit has not been tested on Windows NT®, Windows 2000® 
or Microsoft Vista™ operating systems)
© 2009 Microchip Technology Inc. DS61144D-page 11
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2.4.2 View the Getting Started Tutorial
Perform the following steps to view the tutorial:
1. After your computer has rebooted, the Getting Started Tutorial menu opens. 
2. View the tutorial instructions for connecting to the starter kit board and running 

the tutorial project.
If you performed the installation steps as you followed along in the Getting Started 
tutorial, skip to Section 2.5 “Starting the Tutorial Project” on page 16.
If you did not, continue to the next page for instructions about how to connect the board 
and install the device driver.

2.4.3 Connect the Starter Kit Board
Using the supplied USB cable, connect the board to an open USB port on your com-
puter. (A USB hub that is not bus-powered can also be used.) Connect the other end 
of the cable into the USB connector on the starter kit board.
Check the board: the green power LED D3 should be lit. If it is not, check the 
connections at the port, hub, and board.

2.4.4 Install the USB Device Driver

Perform the following steps to install the USB device driver:
1. When the USB cable is connected, the “Found New Hardware Wizard” dialog 

box opens, as shown in Figure 2-2. When asked whether to install the software 
automatically or install from a list or specific location, select “Install software 
automatically” and click Next. 

FIGURE 2-2: FOUND NEW HARDWARE WIZARD 

Note: The USB driver installation steps described here refer specifically to 
installing the driver on a Microsoft Windows XP operating system.
© 2009 Microchip Technology Inc. DS61144D-page 13
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2. As shown in Figure 2-3, the next dialog box tracks the wizard as it searches for 
the device. (This activity may take several seconds.) When it is done, click Next. 

FIGURE 2-3: HARDWARE WIZARD – SEARCHING FOR DEVICE

3. If prompted to select a driver, select mp32mxsk.inf, as shown in Figure 2-4. Click 
Next to continue. 

FIGURE 2-4: HARDWARE WIZARD – SELECTING THE DRIVER
DS61144D-page 14 © 2009 Microchip Technology Inc.
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4. If prompted with a dialog box for Windows Logo testing, as shown in Figure 2-5, 
click Continue Anyway.

FIGURE 2-5: WINDOWS LOGO TESTING 

5. The next window (Figure 2-6) indicates that the installation of the software for the 
starter kit is complete. Click Finish.

FIGURE 2-6: COMPLETING DEVICE DRIVER INSTALLATION
© 2009 Microchip Technology Inc. DS61144D-page 15
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2.5 STARTING THE TUTORIAL PROJECT
Click the MPLAB IDE icon on your computer desktop. The MPLAB IDE opens with the 
starter kit tutorial project loaded, as shown in Figure 2-7. If the MPLAB IDE does not 
have the starter kit tutorial project loaded, select File>Open Workspace... from the 
menu bar and browse to the tutorial project file:
[install directory]\PIC32 Starter Kits\ 
Starter_Kit_Tutorial\starter_kit_tutorial.mcw
(or browse to the file path you used when you installed the MPLAB IDE).
The pane on the left of the MPLAB IDE interface displays project files, the ‘.c’, ‘.h’ and 
‘.a’ files that are used to build an application. The project files are organized by type 
into folders.
“Starter Kit Found” should be displayed in the “Output” pane of the MPLAB IDE inter-
face. If you do not see this message, select Debugger>Select Tool>PIC32MX Starter 
Kit from the menu bar. If that sequence fails to find the project, check the driver 
installation, as well as the connections between the hardware and the PC. 

FIGURE 2-7: MPLAB® IDE WORKSPACE 
DS61144D-page 16 © 2009 Microchip Technology Inc.
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2.8 RUNNING THE PROGRAM
Either click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon 
(the turquoise triangle) on the Debug Tool Bar (Figure 2-12) to run the new program. 

FIGURE 2-12: DEBUG WINDOW

2.9 TUTORIAL PROGRAM OPERATION
The starter kit tutorial demonstrates a simple application. The program responds 
according to the user input menu. The program prints the available menu choices to 
the starter kit Output window in the MPLAB IDE. The program flow is shown in 
Figure 2-13.
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The tutorial program includes the Debug Print Library, which facilitates print functional-
ity. A peripheral library header file for flashing the LEDs is also included. The header 
file for print functionality is db_utils.h. 
Depending on the macro definition given in the print header file, the debug print macros 
will be expanded. The print functionality in the tutorial is routed to the Output window 
on the MPLAB PIC32MX tab in the interface window. In order to achieve this, the 
macro definition “PIC32_STARTER_KIT” is added to the MPLAB C Compiler for PIC32 
options.
As the program runs, the Output window (Figure 2-14) tracks the progress.

FIGURE 2-14: OUTPUT WINDOW

After printing the menu, the application displays a prompt that requests your input, see 
Figure 2-15.

FIGURE 2-15: TARGET IN WINDOW

Type your choice into the Enter Information to be Sent to Target box, and click Send. 
The program responds according to the menu entry. Watch the LEDs on the starter kit 
board. If your entry is incorrect, the LEDs will toggle once.
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Create a New Project
FIGURE 3-4: ADDING FILES TO THE PROJECT 

3.3.4 Task 4, Add Files to Your Project
This window can be skipped, since no ‘.c’ files have been created. 
1. Click Next to continue. 
2. Click Finish on the summary screen.
3. A project and workspace have been created in the MPLAB IDE. 

BlinkLED.mcw is the workspace file and BlinkLED.mcp is the project file. 
4. Click File>New from the menu bar to create a new file. A new file is displayed. 
5. Click File>Save As... and save this file as ‘BlinkLED.c’ in the same folder (in this 

case, the C:\MyProject folder). 
6. Now copy the source code provided in Example 3-1 to the BlinkLED.c file. The 

source code file is located in the PIC32 Starter Kit directory: 
[install directory]\PIC32 Starter Kits\Blink_Leds.
© 2009 Microchip Technology Inc. DS61144D-page 27
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EXAMPLE 3-1: PROJECT SOURCE CODE

#include <plib.h>   // Adds support for PIC32 Peripheral library 
functions and macros

void Delay(unsigned int count)

{
while(--count);

}

int main(void)
{

   /* LED setup - Turn off leds before configuring the IO pin as output */

   mPORTDClearBits(BIT_0 | BIT_1 | BIT_2);             // same as LATDCLR = 0x0007

   /* Set RD0, RD1 and RD2 as outputs */

   mPORTDSetPinsDigitalOut(BIT_0 | BIT_1 | BIT_2 );    // same as TRISDCLR = 0x0007

   /* endless loop */

   while(1)
   {

      Delay(200000);

      mPORTDToggleBits(BIT_0); // toggle LED0 (same as LATDINV = 0x0001)

      Delay(200000);

      mPORTDToggleBits(BIT_1); // toggle LED1 (same as LATDINV = 0x0002)

      Delay(200000);

      mPORTDToggleBits(BIT_2); // toggle LED2 (same as LATDINV = 0x0004)
   };

   return 0;

}
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3.3.5 Task 5, Confirm the Configuration Settings
Click Configure>Configuration Bits to confirm that the configuration settings are cor-
rect. Typical configuration settings for the starter kit are shown in Figure 3-6. 

FIGURE 3-6: CONFIGURATION BIT SETTINGS 

Note: The “Configuration Bits set in code” check box must be unchecked if the 
config bits are set via this window and not in the code.
The configuration settings can also be embedded in the source file. 
See the MPLAB C Compiler for PIC32 User’s Guide (DS51686) for  
information.

CAUTION

Setting the PIC32 Starter Kit configuration bits to cause the PIC32MX to oper-
ate faster than the maximum 80MHz system clock speed may cause the 
PIC32MX to stop communicating with the PIC18F4550 Starter Kit debugger. 
Should this occur, run the sk_erase.exe utility to re-flash the PIC32MX with a 
default configuration. This utility is located on the PIC32 Starter Kit CD or in 
the PIC32MX Starter Kit directory:
[install directory]\PIC32 Starter Kits\tools
DS61144D-page 30 © 2009 Microchip Technology Inc.
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3.3.7 Task 7, Program the Device
1. Click the Program All Memories icon on the Program Device Tool Bar, as shown 

in Figure 3-8.

FIGURE 3-8: PROGRAM DEVICE WINDOW

A Programming Warning window (Figure 3-9) opens to warn you about overwriting the 
memory. 
2. Click Yes. 

FIGURE 3-9: PROGRAMMING WARNING WINDOW

The Output window (Figure 3-10) tracks the progress of the output. “Done” signals that 
the programming of the device is complete.

FIGURE 3-10: OUTPUT WINDOW
DS61144D-page 32 © 2009 Microchip Technology Inc.
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Chapter 4.  PIC32MX Starter Kit Hardware
4.1 INTRODUCTION
This chapter describes the hardware features of the PIC32MX Starter Kit. 

4.2 HARDWARE FEATURES
The key features of the PIC32MX Starter Kit are listed below. They are presented in the 
order given in Section 1.4 “PIC32MX Functionality and Features”. You can refer to 
Figure 1-1 on page 8 for their locations on the board.

4.2.1 Processor Support
The PIC32MX Starter Kit is designed with a permanently mounted (i.e., soldered) 
PIC32MX360F512L processor.

4.2.2 Power Supply
There are two ways to supply power to the PIC32MX Starter Kit:

• USB bus power connected to J1.
• An external application board with a regulated DC power supply that provides +5V 

can be connected to the J2 application board connector that is provided on the 
bottom side of the board.

One green LED (D3) is provided to show that the PIC32 microcontroller is powered up.

4.2.3 USB Connectivity
The PIC32MX Starter Kit includes a PIC18LF4550 USB microcontroller, which provides 
both USB connectivity and support for protocol translation. The PIC18LF4550 is 
hard-wired to the PIC32MX device to provide two types of connectivity:
• I/O pins of PIC18LF4550 to ICSP™ pins of PIC32MX
• I/O pins of PIC18LF4550 to JTAG pins of PIC32MX
The PIC32MX Starter Kit currently uses the JTAG pins of the PIC32MX device for 
programming and debugging.

Note: The basic PIC32MX Starter Kit does not include an application board and 
is intended to be USB-bus powered. 
© 2009 Microchip Technology Inc. DS61144D-page 35
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Appendix A. PIC32MX Starter Kit Schematics
A.1 INTRODUCTION
This section provides detailed technical information about the PIC32MX Starter Kit.

A.2 DEVELOPMENT BOARD BLOCK DIAGRAM

FIGURE A-1: HIGH-LEVEL BLOCK DIAGRAM OF THE PIC32MX STARTER KIT

A.3 STARTER KIT BOARD SCHEMATICS
Figure A-2. PIC32MX CPU
Figure A-3. PIC18LF4550 Debug CPU
Figure A-4. Application Board Connector
Figure A-5. Switches and LEDs
Figure A-6. Power Supply

PIC32MX360F512L

PIC18LF4550

ICSP™
JTAG

Power 
Supply
+3.3V

VUSB or
+5V_EXT

Switches

LEDs

USB

Ap
pl

ic
at

io
n 

Bd
. C

on
ne

ct
or
© 2009 Microchip Technology Inc. DS61144D-page 37



PIC
32M

X Starter K
it U

ser’s G
uide

D
S

61144D
-page 38

©
 2009 M

icrochip Technology Inc.
FIGURE A-2:PIC32MX SCHEMATIC, SHEET 1 OF 6 (PIC32MX CPU)



PIC32MX STARTER KIT
 USER’S GUIDE
Index
A
Active Toolsuite ...................................................... 25

B
Building the tutorial project ..................................... 17

C
Connect the Starter Kit Board ................................. 13
Create a Project

Build the Project .............................................. 31
Configuration settings ...................................... 30

Customer Change Notification Service ..................... 4
Customer Support ..................................................... 4

D
Debug print library .................................................. 21
Documentation

Conventions ....................................................... 2

H
Hardware Features

LEDs ................................................................ 36
Oscillator Options ............................................ 36
PICtail Plus Card Edge Connectors ................ 36
Power Supply .................................................. 35
Processor Support ........................................... 35
Switches .......................................................... 36
USB Connectivity ............................................. 35

Host Computer Requirements ................................ 11

I
Installing The Starter Kit Board ............................... 12
Installing the USB Device Driver ............................. 13
Internet Address ....................................................... 3

L
Language Toolsuite ................................................ 25
Last Schematic ....................................................... 42
LEDs

Power .............................................................. 13

M
Microchip Internet Web Site ...................................... 3
MPLAB ...................................................................... 9
MPLAB IDE Simulator, Editor User’s Guide ............. 3

P
PIC32MX

Layout
32-bit microcontroller .................................. 8
Connector for expansion boards ................ 8
Debug indicator LED .................................. 8
On-board crystal ......................................... 8
PIC18LF4550 USB microcontroller ............ 8
Power supply .............................................. 8
Power-indicator LED ................................... 8
Switches ..................................................... 8
USB connectivity ........................................ 8
User-defined LEDs ..................................... 8

PIC32MX Out of the box ........................................... 9
Preprogrammed game ....................................... 9

Preprogrammed example code ................................. 9
print functionality ..................................................... 21
Project Wizard ......................................................... 23

R
Readme 3
Restore PIC32MX original programming .................. 9

S
Schematics

Application Board Connector ........................... 40
PIC18LF4550 Debug CPU .............................. 39
PIC32MX CPU ................................................. 38
Power Supply ................................................... 42
Switches and LEDs .......................................... 41

Starter Kit Board
Block Diagram ................................................. 37
Connecting ....................................................... 13
Installing ........................................................... 12
Installing device driver ..................................... 13

T
Tutorial Program Operation .................................... 19
Tutorial Project

Program operation ........................................... 19
Programming the device .................................. 18
Starting ............................................................ 16

U
USB

Connectivity ..................................................... 35

W
WWW Address .......................................................... 3
© 2009 Microchip Technology Inc. DS61144D-page 43



DS61144D-page 44 © 2009 Microchip Technology Inc.

AMERICAS
Corporate Office
2355 West Chandler Blvd.
Chandler, AZ  85224-6199
Tel:  480-792-7200  
Fax:  480-792-7277
Technical Support: 
http://support.microchip.com
Web Address: 
www.microchip.com
Atlanta
Duluth, GA 
Tel: 678-957-9614 
Fax: 678-957-1455
Boston
Westborough, MA  
Tel: 774-760-0087 
Fax: 774-760-0088
Chicago
Itasca, IL  
Tel: 630-285-0071 
Fax: 630-285-0075
Cleveland
Independence, OH 
Tel: 216-447-0464 
Fax: 216-447-0643
Dallas
Addison, TX 
Tel: 972-818-7423  
Fax: 972-818-2924
Detroit
Farmington Hills, MI 
Tel: 248-538-2250
Fax: 248-538-2260
Kokomo
Kokomo, IN 
Tel: 765-864-8360
Fax: 765-864-8387
Los Angeles
Mission Viejo, CA 
Tel: 949-462-9523  
Fax: 949-462-9608
Santa Clara
Santa Clara, CA 
Tel: 408-961-6444
Fax: 408-961-6445
Toronto
Mississauga, Ontario, 
Canada
Tel: 905-673-0699  
Fax:  905-673-6509

ASIA/PACIFIC
Asia Pacific Office
Suites 3707-14, 37th Floor
Tower 6, The Gateway
Harbour City, Kowloon
Hong Kong
Tel: 852-2401-1200
Fax: 852-2401-3431
Australia - Sydney
Tel: 61-2-9868-6733
Fax: 61-2-9868-6755
China - Beijing
Tel: 86-10-8528-2100 
Fax: 86-10-8528-2104
China - Chengdu
Tel: 86-28-8665-5511
Fax: 86-28-8665-7889
China - Hong Kong SAR
Tel: 852-2401-1200  
Fax: 852-2401-3431
China - Nanjing
Tel: 86-25-8473-2460
Fax: 86-25-8473-2470
China - Qingdao
Tel: 86-532-8502-7355
Fax: 86-532-8502-7205
China - Shanghai
Tel: 86-21-5407-5533  
Fax: 86-21-5407-5066
China - Shenyang
Tel: 86-24-2334-2829
Fax: 86-24-2334-2393
China - Shenzhen
Tel: 86-755-8203-2660 
Fax: 86-755-8203-1760
China - Wuhan
Tel: 86-27-5980-5300
Fax: 86-27-5980-5118
China - Xiamen
Tel: 86-592-2388138 
Fax: 86-592-2388130
China - Xian
Tel: 86-29-8833-7252
Fax: 86-29-8833-7256
China - Zhuhai
Tel: 86-756-3210040 
Fax: 86-756-3210049

ASIA/PACIFIC
India - Bangalore
Tel: 91-80-3090-4444 
Fax: 91-80-3090-4080
India - New Delhi
Tel: 91-11-4160-8631
Fax: 91-11-4160-8632
India - Pune
Tel: 91-20-2566-1512
Fax: 91-20-2566-1513
Japan - Yokohama
Tel: 81-45-471- 6166  
Fax: 81-45-471-6122
Korea - Daegu
Tel: 82-53-744-4301
Fax: 82-53-744-4302
Korea - Seoul
Tel: 82-2-554-7200
Fax: 82-2-558-5932 or 
82-2-558-5934
Malaysia - Kuala Lumpur
Tel: 60-3-6201-9857
Fax: 60-3-6201-9859
Malaysia - Penang
Tel: 60-4-227-8870
Fax: 60-4-227-4068
Philippines - Manila
Tel: 63-2-634-9065
Fax: 63-2-634-9069
Singapore
Tel:  65-6334-8870
Fax: 65-6334-8850
Taiwan - Hsin Chu
Tel: 886-3-572-9526
Fax: 886-3-572-6459
Taiwan - Kaohsiung
Tel: 886-7-536-4818
Fax: 886-7-536-4803
Taiwan - Taipei
Tel: 886-2-2500-6610  
Fax: 886-2-2508-0102
Thailand - Bangkok
Tel: 66-2-694-1351
Fax: 66-2-694-1350

EUROPE
Austria - Wels
Tel: 43-7242-2244-39
Fax: 43-7242-2244-393
Denmark - Copenhagen
Tel: 45-4450-2828 
Fax: 45-4485-2829
France - Paris
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-30-90-79
Germany - Munich
Tel: 49-89-627-144-0 
Fax: 49-89-627-144-44
Italy - Milan 
Tel: 39-0331-742611  
Fax: 39-0331-466781
Netherlands - Drunen
Tel: 31-416-690399 
Fax: 31-416-690340
Spain - Madrid
Tel: 34-91-708-08-90
Fax: 34-91-708-08-91
UK - Wokingham
Tel: 44-118-921-5869
Fax: 44-118-921-5820

WORLDWIDE SALES AND SERVICE
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