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Welcome to E-XFL.COM

What is "Embedded - Microcontrollers"?

"Embedded - Microcontrollers" refer to small, integrated
circuits designed to perform specific tasks within larger
systems. These microcontrollers are essentially compact
computers on a single chip, containing a processor core,
memory, and programmable input/output peripherals.
They are called "embedded" because they are embedded
within electronic devices to control various functions,
rather than serving as standalone computers.
Microcontrollers are crucial in modern electronics,
providing the intelligence and control needed for a wide
range of applications.

Applications of "Embedded -
Microcontrollers"

Embedded microcontrollers are used in virtually every
sector of electronics, providing the necessary control and
processing power for a multitude of applications. In
consumer electronics, they manage the operations of
smartphones, home appliances, and wearable devices. In
automotive systems, microcontrollers control engine
functions, safety features, and infotainment systems.
Industrial applications rely on microcontrollers for
automation, robotics, and process control. Additionally,
microcontrollers are integral in medical devices, handling
functions such as monitoring, diagnostics, and control of
therapeutic equipment. Their versatility and
programmability make them essential components in
creating efficient, responsive, and intelligent electronic
systems.

Common Subcategories of "Embedded -
Microcontrollers"

Embedded microcontrollers can be categorized based on
their architecture, performance, and application focus.
Common subcategories include 8-bit, 16-bit, and 32-bit
microcontrollers, differentiated by their processing power
and memory capacity. 8-bit microcontrollers are typically
used in simple applications like basic control systems and
small devices. 16-bit microcontrollers offer a balance
between performance and complexity, suitable for
medium-scale applications like industrial automation. 32-
bit microcontrollers provide high performance and are
used in complex applications requiring advanced
processing, such as automotive systems and sophisticated
consumer electronics. Each subcategory serves a specific
range of applications, providing tailored solutions for
different performance and complexity needs.

Types of "Embedded - Microcontrollers"

There are various types of embedded microcontrollers,
each designed to meet specific application requirements.
General-purpose microcontrollers are versatile and used in
a wide range of applications, offering a balance of
performance, memory, and peripheral options. Special-
purpose microcontrollers are tailored for specific tasks,
such as automotive controllers, which include features like
built-in motor control peripherals and automotive-grade
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PIC32MX Starter Kit User’s Guide
CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or dialog “Save project before build”
Underlined, italic text with right 
angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants (in source code) 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be any 
valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, var_name...]

Represents code supplied by user void main (void)
{ ...
}
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Preface
DOCUMENT REVISION HISTORY 

Revision A (October 2007)
This is the initial release of the PIC32MX Starter Kit User’s Guide.

Revision B (October 2007)
Removed confidential status.

Revision C (November 2008)
Updated the instructions in Section 3.3.2 “Task 2, Select the Language Toolsuite”.
Added connector table in Section Table 4-1: “Starter Board Connector Part 
Numbers”.

Revision D (February 2009)
Updated directory names and associated figures.
© 2009 Microchip Technology Inc. DS61144D-page 5



PIC32MX Starter Kit User’s Guide
NOTES:
DS61144D-page 6 © 2009 Microchip Technology Inc.



PIC32MX STARTER KIT
USER’S GUIDE
Chapter 1.  Introducing the PIC32MX Starter Kit
1.1 INTRODUCTION
Thank you for purchasing the Microchip Technology PIC32MX Starter Kit. This kit 
provides a low-cost, modular development system for Microchip’s new line of 32-bit 
microcontrollers. 
The starter kit comes pre-loaded with demonstration software for the user to explore 
the new features of the PIC32MX. It is also expandable through a modular expansion 
interface, which allows the user to extend its functionality. The PIC32MX Starter Kit also 
supplies on-board circuitry for full debug and programming capabilities.

1.2 HIGHLIGHTS
This chapter covers the following topics:
• Kit Contents
• PIC32MX Functionality and Features
• Installing the PIC32MX Starter Kit CD
• Using the PIC32MX Starter Kit Out of the Box
• PIC32MX Demonstration Program
The preprogrammed example code on the PIC32MX MCU has been included on the 
PIC32MX Starter Kit CD-ROM for future reference. All project files have been included, 
so that the code may be used directly to restore the PIC32MX MCU on the starter kit 
to its original state (i.e., if the sample device has been reprogrammed with another 
program), or so you can use the tutorial code as a platform for further experimentation.

1.3 KIT CONTENTS
The PIC32MX Starter Kit contains the following items:
• PIC32MX Starter Kit Board
• USB Mini-B cable
• PIC32 Starter Kit Installation CD-ROM, which includes:

- PIC32MX Starter Kit User’s Guide (DS61144)
- PIC32MX Family Data Sheet (DS61143)
- PIC32MX Family Reference Manual (DS61132)
- PIC32MX Peripheral Library Manual
- Code examples for use with the PIC32MX devices

If you are missing any part of the kit, contact a Microchip sales office for assistance. A 
list of Microchip offices for sales and service is provided on page 44.
© 2009 Microchip Technology Inc. DS61144D-page 7
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1.4 PIC32MX FUNCTIONALITY AND FEATURES
A representation of the layout of the PIC32MX Starter Kit is shown in Figure 1-1. The 
board includes these key features, as indicated in the diagram: 
1. PIC32MX360F512L 32-bit microcontroller
2. Green power-indicator LED
3. Regulated +3.3V power supply for powering the starter kit board via USB or 

expansion board
4. On-board crystal for precision microcontroller clocking (8 MHz)
5. USB connectivity for on-board debugger communications
6. PIC18LF4550 USB microcontroller for on-board debugging
7. Orange Debug indicator LED
8. Three push-button switches for user-defined inputs
9. Three user-defined indicator LEDs
10.  Connector for connecting various expansion boards (on the underside of board)
For details on these features, refer to Chapter 4. “PIC32MX Starter Kit Hardware”.

FIGURE 1-1: PIC32MX STARTER KIT DEMO BOARD LAYOUT

1

10

7

4

5

6

3

2

8

9

M

DS61144D-page 8 © 2009 Microchip Technology Inc.



PIC32MX Starter Kit Tutorial
The tutorial program includes the Debug Print Library, which facilitates print functional-
ity. A peripheral library header file for flashing the LEDs is also included. The header 
file for print functionality is db_utils.h. 
Depending on the macro definition given in the print header file, the debug print macros 
will be expanded. The print functionality in the tutorial is routed to the Output window 
on the MPLAB PIC32MX tab in the interface window. In order to achieve this, the 
macro definition “PIC32_STARTER_KIT” is added to the MPLAB C Compiler for PIC32 
options.
As the program runs, the Output window (Figure 2-14) tracks the progress.

FIGURE 2-14: OUTPUT WINDOW

After printing the menu, the application displays a prompt that requests your input, see 
Figure 2-15.

FIGURE 2-15: TARGET IN WINDOW

Type your choice into the Enter Information to be Sent to Target box, and click Send. 
The program responds according to the menu entry. Watch the LEDs on the starter kit 
board. If your entry is incorrect, the LEDs will toggle once.
© 2009 Microchip Technology Inc. DS61144D-page 21
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3.3.1 Task 1, Select a Device
1. Start MPLAB IDE.
2. Click File>Close Workspace on the menu bar, to close any workspace that is 

open. 
3. Click Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is 

displayed, as shown in Figure 3-1. 

FIGURE 3-1: SELECTING THE DEVICE

5. From the “Device” drop-down list, select “PIC32MX360F512L”. 
6. Click Next. The Project Wizard Step Two: dialog box opens, as shown in 

Figure 3-2.
DS61144D-page 24 © 2009 Microchip Technology Inc.
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FIGURE 3-3: NAMING YOUR PROJECT

3.3.3 Task 3, Name Your Project
1. In the “Create New Project File” field, type C:\MyProject\BlinkLED.
2. Click Next and Ok to continue. The Project Wizard Step Four: dialog opens, as 

shown in Figure 3-4.
DS61144D-page 26 © 2009 Microchip Technology Inc.



Create a New Project
FIGURE 3-4: ADDING FILES TO THE PROJECT 

3.3.4 Task 4, Add Files to Your Project
This window can be skipped, since no ‘.c’ files have been created. 
1. Click Next to continue. 
2. Click Finish on the summary screen.
3. A project and workspace have been created in the MPLAB IDE. 

BlinkLED.mcw is the workspace file and BlinkLED.mcp is the project file. 
4. Click File>New from the menu bar to create a new file. A new file is displayed. 
5. Click File>Save As... and save this file as ‘BlinkLED.c’ in the same folder (in this 

case, the C:\MyProject folder). 
6. Now copy the source code provided in Example 3-1 to the BlinkLED.c file. The 

source code file is located in the PIC32 Starter Kit directory: 
[install directory]\PIC32 Starter Kits\Blink_Leds.
© 2009 Microchip Technology Inc. DS61144D-page 27
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3.3.5 Task 5, Confirm the Configuration Settings
Click Configure>Configuration Bits to confirm that the configuration settings are cor-
rect. Typical configuration settings for the starter kit are shown in Figure 3-6. 

FIGURE 3-6: CONFIGURATION BIT SETTINGS 

Note: The “Configuration Bits set in code” check box must be unchecked if the 
config bits are set via this window and not in the code.
The configuration settings can also be embedded in the source file. 
See the MPLAB C Compiler for PIC32 User’s Guide (DS51686) for  
information.

CAUTION

Setting the PIC32 Starter Kit configuration bits to cause the PIC32MX to oper-
ate faster than the maximum 80MHz system clock speed may cause the 
PIC32MX to stop communicating with the PIC18F4550 Starter Kit debugger. 
Should this occur, run the sk_erase.exe utility to re-flash the PIC32MX with a 
default configuration. This utility is located on the PIC32 Starter Kit CD or in 
the PIC32MX Starter Kit directory:
[install directory]\PIC32 Starter Kits\tools
DS61144D-page 30 © 2009 Microchip Technology Inc.
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3.3.7 Task 7, Program the Device
1. Click the Program All Memories icon on the Program Device Tool Bar, as shown 

in Figure 3-8.

FIGURE 3-8: PROGRAM DEVICE WINDOW

A Programming Warning window (Figure 3-9) opens to warn you about overwriting the 
memory. 
2. Click Yes. 

FIGURE 3-9: PROGRAMMING WARNING WINDOW

The Output window (Figure 3-10) tracks the progress of the output. “Done” signals that 
the programming of the device is complete.

FIGURE 3-10: OUTPUT WINDOW
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Create a New Project
3.3.8 Task 8, Run the Program
Click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon (the 
turquoise triangle) on the Debug Tool Bar, as indicated in Figure 3-11, to run the new 
program. 

FIGURE 3-11: RUN THE PROGRAM

The starter kit LEDs blink to indicate that the program is running successfully. 
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FIG
URE A-3: PIC32MX SCHEMATIC, SHEET 2 OF 6 (PIC18LF4550 DEBUG CPU)



PIC32MX Starter Kit User’s Guide
FIGURE A-4: PIC32MX SCHEMATIC, SHEET 3 OF 6 (APPLICATION BOARD CONNECTOR)
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FIGURE A-6: PIC32MX SCHEMATIC, SHEET 6 OF 6 (POWER SUPPLY)
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